RU/2: Forum. Discussion for users and developer OS/2 (eCS). : Ядро OS/4 и ArcaOS


Message list | Post new message | Reply to current | Home Search:
Previous message | Next message
From : valerius
To : Improver
Subj : Ядро OS/4 и ArcaOS

> > > И ещё, в АОС 5.0.1.3 для запуска на ядре OS4 достаточно заменить только этот файл, остальные файлы от ACPI 3.23.07, по всей видимости, совместимы с 3.23.01. :-)
> > >
> >
> > а lxlite-ом распаковывал?
>
> Нет...
>

Попробуй сначала распаковать, и потом снова запатчить. Если после распаковки размер изменился, то распаковывать было таки надо

> > Хотя еще возможно, что при распаковке разными версиями lxlite могут получиться разные бинарники. Возможно еще, что это действительно немного разные бинарники, у которых почему-то забыли поменять версию. Судя по размеру, это не-дебаговый, как и у меня. Дебаговый весит около 400 КБ. Лицензирована -- да, но не думаю, что у патченных бинарников для разных юзеров разный размер. Скорее всего, они просто патчат бинарник. Но с другой стороны теоретически возможно, что они для разных юзеров они перелинковывают бинарник. Так ли это, неизвестно. Если так, то жёппа...
>
> Да, там всё хитро сделали... Простым поиском по строке мой адрес не находится, видимо запакован/зашифрован. Но то, что он там есть -- это точно, т.к. при замене всего одного этого файла меняется надпись "лицензировано для того-то...".
>

да, что зашифровали, это точно. Еще хуже, если они каждый бинарник под конкретного юзера пересобирают. Это в смысле, если кому-то понадобится "хакнуть", чтобы можно было можно потом с народом поделиться ;) Но этим заниматься щас некому. Раньше был RElf & Co, а щас таких спецов почти не осталось. Тем не менее, запатчить на предмет стека (то, что делал предыдущий патч) это не должно мешать. Я подозреваю, что трапается у тебя из-за того, что ты забыл распаковать.

> И вчера вечером с ним меня ждал облом -- этот патченный acpi.psd на реальном железе стабильно вызывал трап 000е, хотя в виртуалке было всё ок. Попробовал пропатчить версию 3.22.03 -- тоже трап... Думаю, надо переходить на acpi4.bpd. :-)

попробуй-таки сначала распаковать и снова запатчить. Но конечно, странно, что в виртуалке работает, а на реальной трапается. acpi4.bpd да, это дело. Жаль тока, что аналога apm.add пока нету. На ноутах приходится работать без суспенда и вгоняния проца в HLT. Батарейка садится быстро :( К сожалению, у AlexT нету ноута, и ему это не актуально, похоже

> > > 2. Как подавить вывод загружаемых драйверов? Ну или хотя бы тех, что "ок".
> >
> > Никак. А зачем его подавлять? Всегда включаю verbose режим, потому что так легче заметить ошибку, если что-то не работает
>
> Ну, привык я к минимуму сообщений... А если будет ошибка, то пробегающие строки с "ок" не сдвинут её за пределы экрана -- успеешь прочитать. :-)

Ошибка тут не особо мешает. Если что, по Alt-F5 пошагово проходишь конфиг.сыс, ну или ставишь PAUSEONERROR=YES и добавляешь в нужное место ошибку в конфиг, Например несуществующий драйвер прописывает. Тогда загрузка остановится в месте ошибки, и можно будет посмотреть предыдущее сообщение. -- Я так обычно делаю. Ну, или еще есть драйвер delay.sys, который на ините делает задержкую


Fri 26 Jan 2018 23:16 Mozilla/5.0 (OS/2; Warp 4.5; rv:38.0) Gecko/20100101 Firefox




Programmed by Dmitri Maximovich, Dmitry I. Platonoff, Eugen Kuleshov.
25.09.99 (c) 1999, RU/2. All rights reserved.
Rewritten by Dmitry Ban. All rights ignored.