RU/2: Forum. Discussion for users and developer OS/2 (eCS). : менеджеры пакетов


Message list | Post new message | Reply to current | Home Search:
Previous message | Next message
From : valerius
To : DDP
Subj : менеджеры пакетов

> > > > > скажите, надо использовать оба: юм и второй, или достаточно обойтись одним?
> > > >
> > > > какой второй?
> > > ну, этот, второй. что-то типа анпм, или как там его. от ковчега.
> > >
> > >
> >
> > Насколько я понимаю, ANPM это графическая морда к yum. Т.е., она требует установленного yum, и может быть использована
> > вместо него. Для непродвинутого юзера может быть удобнее. ANPM вроде, написан на VXREXX-е.
> >
> > Кроме йума, есть еще rpm. Они друг друга дополняют, первый нужен для управления удаленными репозиториями, и автоматической установки всех пакетов с зависимостями, а второй нужен для понимания самогО формата пакетов и установки пакета из локального
> > файла.
> тут я совсем запутался.
> что устанавливать сначала? есть yum bootstrap для пентиума 4.
> устанавливаю.
> далее как в ридми: запускаем, поинструкции, перегружаемся, yum install yum или yum install rpm выдают ошибку и просят что-то установить вручную. это "что-то" в репозитории не обнаружено. после установки anpm юм перестаёт работать вообще.

Ты "yum install yum" откуда запускаешь? Там после установки .WPI с бутстрапом должна появиться
иконка на десктопе. Вот по ней надо кликнуть, запустится сеанс комстроки с нужными переменными
окружения. Если ты запустишь не это окно, а обычный сеанс CMD.EXE, естественно, yum bootstrap
не будет на путях и ничего не найдется.

Thu 08 Nov 2018 04:49 Mozilla/5.0 (OS/2; Warp 4.5; rv:38.0) Gecko/20100101 Firefox




Programmed by Dmitri Maximovich, Dmitry I. Platonoff, Eugen Kuleshov.
25.09.99 (c) 1999, RU/2. All rights reserved.
Rewritten by Dmitry Ban. All rights ignored.