RU/2: Forum. Discussion for users and developer OS/2 (eCS). : менеджеры пакетов


Message list | Post new message | Reply to current | Home Search:
Previous message | Next message
From : LightElf
To : valerius
Subj : менеджеры пакетов

> потому что разные проги юзают разные версии библиотек. Желательно юзать последнюю, чтобы
> работали все из них. Поэтому всю систему портов надо обновлять, чтобы все проги юзали ту же
> версию каждой либы. Это yum делает автоматически. Можно конечно, для каждой проги юзать свою
> версию каждой либы, но тогда если сначала загрузится более старая версия либы в одной программе,
> а потом ты запустишь вторую прогу, которой нужна более новая версия той же либы, и в резутьтате
> вторая прога упадет. Можно юзать LIBPATHSTRICT=T, но вот на моей машине он почему-то не работает,
> к тому же, если даже это заработает, то надо обе версии либы грузить одновременно в память, а
> памяти в 32-битной системе и так мало. Поэтому лучше юзать йум. Он обновит все либы до нужного
> уровня, и установит все нужные зависимости автоматически.

Статическая линковка? Нет, не слышал..
тьтате
> вторая прога упадет. Можно юзать LIBPATHSTRICT=T, но вот на моей машине он почему-то не работает,
> к тому же, если даже это заработает, то надо обе версии либы грузить одновременно в память, а
> памяти в 32-битной системе и так мало. Поэтому лучше юзать йум. Он обновит все либы до нужного
> уровня, и установит все нужные зависимости автоматически.
>


Tue 13 Nov 2018 16:47 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101




Programmed by Dmitri Maximovich, Dmitry I. Platonoff, Eugen Kuleshov.
25.09.99 (c) 1999, RU/2. All rights reserved.
Rewritten by Dmitry Ban. All rights ignored.